requires PEAR Installer (version >= 1.6.0) などと出た時の pearアップグレード

Linuxのディストリビューションパッケージでpearを入れて、例えばMail_Mimeをインストールした時など、


# pear install Mail_Mime
WARNING: channel "pear.php.net" has updated its protocols, use "channel-update p
ear.php.net" to update
pear/Mail_Mime requires PEAR Installer (version >= 1.6.0), installed version is
1.4.9
pear/Mail_mimeDecode requires PEAR Installer (version >= 1.6.0), installed versi
on is 1.4.9
pear/Mail_mimeDecode requires package "pear/Mail_Mime" (version >= 1.4.0, exclud
ed versions: 1.4.0)
No valid packages found
install failed

pearのバージョン新しくしてよ、と怒られます。でも、WARNINGメッセージ通りに

# pear channel-update pear.php.net

としても、何も変わらないことが多いので、pear upgrade でやってしまいましょう。

# pear upgrade pear

無事、アップグレードできましたでしょうか。

タイトルとURLをコピーしました